Skip to main content

Mail.app compose window won't close

Comments

3 comments

  • Pedro Grilo

    Hi TN!

    We can not reproduce the issue you describe on any OS X version, including on Mavericks. 

    A diagnostic report could help shed some light on the issue, but probably not that much.

    Do you have any plugins, Mail app or System modifications that could be conflicting with Flavours?

    Thank you.

    0
  • TN

    Hi Pedro,

    So here's what happened in details :

    I came across GPG Suite for mac, which allows to add gpg encryption to emails. Along with other stuffs, it installs a plugin for Mail.app to encrypt mails on the fly. I never really used Mail.app on this system, since I rely on other softwares, but I did launch it once when I first added an email account in the system account preferences. So after installing gpg suite, I launched Mail.app for the 2nd time. Flavours was on. It's then that I noticed I couldn't close the compose window (not in fullscreen btw, and using the red close button, along with the File>Close window workflow). I tried lot of things, beginning by closing and force closing Mail.app but only deleting prefs in Library would take Mail.app to work normally again, until I opened a new compose window and then, I was back at start point.

    So I turned Flavours off, logged out, then in, and Mail.app compose window behave normally. I could close it again. I assumed that it was caused by Flavours and filed a bug here. After that, I turned Flavours on again and began to use Mail.app in fullscreen, so compose windows are no more separate windows, but overlays with "send" and "cancel" buttons. I assumed the bug was still active.

    When I received the notice from you answer in my mail box, I tried again, in normal screen and Flavours on, to close a compose window, and the bug had disappeared. So now, I can't reproduce it anymore...

    Maybe it was a false alarm, I don't know, but in the first place turning off flavours definitely removed the bug. I didn't try to close a compose window again immediately after turning Flavours back on though...

    Sorry if I mislead you.

    0
  • Pedro Grilo

     Hi TN,

    Thank you for clarifying that up. The GPG Suite's plugin you mention could had caused that..

    Anyway, I'm glad the issue is gone. If it reoccurs, and you relate it to Flavours, please update us!

    Thank you! 

    0

Please sign in to leave a comment.

Powered by Zendesk